<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>Do not delay - AM 930 The Light</title>
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.am930thelight.com/xmlrpc.php">


<!-- This site is optimized with the Yoast SEO plugin v3.4.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.am930thelight.com/blog/do-not-delay/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Do not delay - AM 930 The Light" />
<meta property="og:description" content="April 16 – Do not delay – Psalm 40:16-17      David writes in these final verses of this psalm that all those who seek the Lord will rejoice and be..." />
<meta property="og:url" content="http://www.am930thelight.com/blog/do-not-delay/" />
<meta property="og:site_name" content="AM 930 The Light" />
<meta property="article:section" content="Uncategorized" />
<meta property="article:published_time" content="2018-04-16T04:30:48-06:00" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="AM 930 The Light &raquo; Feed" href="http://www.am930thelight.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="AM 930 The Light &raquo; Comments Feed" href="http://www.am930thelight.com/comments/feed/" />

<script>
var MP3jPLAYLISTS = [];
var MP3jPLAYERS = [];
</script>
<link rel="alternate" type="text/calendar" title="AM 930 The Light &raquo; iCal Feed" href="http://www.am930thelight.com/events/?ical=1" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.am930thelight.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.6"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jquery-style-css'  href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='widget-calendar-pro-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-calendar-full.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='tribe_events-widget-calendar-pro-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-calendar-theme.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='tribe_events--widget-calendar-pro-override-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-calendar-theme.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='cmc-style-css'  href='http://www.am930thelight.com/wp-content/plugins/dmg-christmas-miracles/cmc-styles.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='program-schedule-css'  href='http://www.am930thelight.com/wp-content/plugins/radio-station/templates/program-schedule.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='dj-widget-css'  href='http://www.am930thelight.com/wp-content/plugins/radio-station/templates/djonair.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='wprmenu.css-css'  href='http://www.am930thelight.com/wp-content/plugins/wp-responsive-menu/css/wprmenu.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='wprmenu-font-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C300%2C600&#038;ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-full-pro-calendar-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-full.min.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-pro-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-theme.min.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-full-pro-mobile-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-full-mobile.min.css?ver=4.1.3' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='tribe-events-calendar-pro-mobile-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/tribe-events-pro-theme-mobile.min.css?ver=4.1.3' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.am930thelight.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='grid-css'  href='http://www.am930thelight.com/wp-content/themes/shine-fm/css/simplegrid.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='shine-fm-style-css'  href='http://www.am930thelight.com/wp-content/themes/shine-fm/style.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='upw_theme_standard-css'  href='http://www.am930thelight.com/wp-content/plugins/ultimate-posts-widget/css/upw-theme-standard.min.css?ver=4.8.6' type='text/css' media='all' />
<link rel='stylesheet' id='widget-this-week-pro-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-this-week-full.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='tribe_events-widget-this-week-pro-style-css'  href='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-this-week-theme.min.css?ver=4.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='mp3-jplayer-css'  href='http://www.am930thelight.com/wp-content/plugins/mp3-jplayer/css/v1-skins/v1-silver.css?ver=2.7' type='text/css' media='all' />
<script type='text/javascript' src='http://www.am930thelight.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/disable-gravity-forms-fields/disable-gf-fields.js?ver=4.8.6'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/wp-responsive-menu/js/jquery.transit.min.js?ver=4.8.6'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/wp-responsive-menu/js/jquery.sidr.js?ver=4.8.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wprmenu = {"zooming":"yes","from_width":"782","swipe":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/wp-responsive-menu/js/wprmenu.js?ver=4.8.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tribe_this_week = {"ajaxurl":"http:\/\/www.am930thelight.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/events-calendar-pro/src/resources/js/widget-this-week.min.js?ver=4.1.3'></script>
<link rel='https://api.w.org/' href='http://www.am930thelight.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.am930thelight.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.am930thelight.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://www.am930thelight.com/?p=12044' />
<link rel="alternate" type="application/json+oembed" href="http://www.am930thelight.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.am930thelight.com%2Fblog%2Fdo-not-delay%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.am930thelight.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.am930thelight.com%2Fblog%2Fdo-not-delay%2F&#038;format=xml" />
		<style id="wprmenu_css" type="text/css" >
			/* apply appearance settings */
			#wprmenu_bar {
				background: #5777cd;
			}
			#wprmenu_bar .menu_title, #wprmenu_bar .wprmenu_icon_menu {
				color: #F2F2F2;
			}
			#wprmenu_menu {
				background: #5777cd!important;
			}
			#wprmenu_menu.wprmenu_levels ul li {
				border-bottom:1px solid #2e3970;
				border-top:1px solid #455ca5;
			}
			#wprmenu_menu ul li a {
				color: #CFCFCF;
			}
			#wprmenu_menu ul li a:hover {
				color: #606060;
			}
			#wprmenu_menu.wprmenu_levels a.wprmenu_parent_item {
				border-left:1px solid #455ca5;
			}
			#wprmenu_menu .wprmenu_icon_par {
				color: #CFCFCF;
			}
			#wprmenu_menu .wprmenu_icon_par:hover {
				color: #606060;
			}
			#wprmenu_menu.wprmenu_levels ul li ul {
				border-top:1px solid #2e3970;
			}
			#wprmenu_bar .wprmenu_icon span {
				background: #FFFFFF;
			}
			
			#wprmenu_menu.left {
				width:80%;
				left: -80%;
			    right: auto;
			}
			#wprmenu_menu.right {
				width:80%;
			    right: -80%;
			    left: auto;
			}


			
							#wprmenu_bar .wprmenu_icon {
					float: right!important;
					margin-right:0px!important;
				}
				#wprmenu_bar .bar_logo {
					pading-left: 0px;
				}
						/* show the bar and hide othere navigation elements */
			@media only screen and (max-width: 782px) {
				html { padding-top: 42px!important; }
				#wprmenu_bar { display: block!important; }
				div#wpadminbar { position: fixed; }
							}
		</style>
		<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://www.am930thelight.com"><link rel="https://theeventscalendar.com" href="http://www.am930thelight.com/wp-json/tribe/events/v1/" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.am930thelight.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://www.am930thelight.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->
<!-- WordPress Facebook Open Graph protocol plugin (WPFBOGP v2.0.13) http://rynoweb.com/wordpress-plugins/ -->
<meta property="fb:app_id" content="555690091232270"/>
<meta property="og:url" content="http://www.am930thelight.com/blog/do-not-delay/"/>
<meta property="og:title" content="Do not delay"/>
<meta property="og:site_name" content="AM 930 The Light"/>
<meta property="og:description" content="April 16 – Do not delay – Psalm 40:16-17       David writes in these final verses of this psalm that all those who seek the Lord will rejoice and be g"/>
<meta property="og:type" content="article"/>
<meta property="og:image" content="http://www.am930thelight.com/wp-content/uploads/sites/3/2014/11/CJCA-Logo-square.png"/>
<meta property="og:locale" content="en_us"/>
<!-- // end wpfbogp -->
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style type="text/css">
		#flourish {		
					 
					background: transparent url(http://www.am930thelight.com/wp-content/uploads/2016/04/flourishbg-cjca.png) center top no-repeat;
					}

		#people {
			position: absolute;
			top: 0;		
					
											width: 198px;
						height: 150px;
											left: 200px;
										background: transparent url(http://www.am930thelight.com/wp-content/uploads/2014/09/familyof3-spring.png) center bottom no-repeat;
					
		}

		h1.site-title {
			display: block;
			width: 200px;
			height: 140px;
			position: absolute;
			top: 8px;
			left: 10px;
		}

		h1.site-title a {
			display: block;
			width: 200px;
			height: 140px;
			text-indent: -9999px;
		}	
	</style>

<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1710496/CJCA-Skyscraper', [160, 600], 'div-gpt-ad-1435266626324-0').addService(googletag.pubads());
    googletag.defineSlot('/1710496/CJCA-SuperCube', [[300, 250], [300, 252]], 'div-gpt-ad-1435266626324-1').addService(googletag.pubads());
    googletag.defineSlot('/1710496/CJCA-Leaderboard', [728, 90], 'div-gpt-ad-1491884663382-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script></head>

<body class="post-template-default single single-post postid-12044 single-format-standard tribe-no-js tribe-theme-shine-fm group-blog site-3 wpb-js-composer js-comp-ver-4.12 vc_responsive">

	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TVQR9Z"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-TVQR9Z');</script>
	<!-- End Google Tag Manager -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=169308996462812&version=v2.0";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div id="flourish">
	<div id="page" class="hfeed site">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<header id="masthead" class="site-header" role="banner">
			<div class="site-branding">
				<h1 class="site-title"><a href="http://www.am930thelight.com/" rel="home">AM 930 The Light</a></h1>
			</div>
			<div id="people"></div>
			
    
    <ul id="onairbox">
                <li id="text-box"><p>Text 74463</p></li>
        <li id="onair-song" onclick="window.location='/songs/';" title="AM930 The Light">
            <b>Currently Playing</b>
            <span>AM930 The Light</span>
            </li>        <li id="onair-live"
            onclick="window.open('http://cjca.streamonfiber.com/player/java/index.php?username=CJCA&stream=44k', '_blank', 'status=yes, resizable=yes'); return false;">
            <b>Listen Live</b>
            Audio Streaming
        </li>
    </ul>


			<nav id="site-navigation" class="main-navigation" role="navigation">
				<button class="menu-toggle">Primary Menu</button>
				<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-151" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151"><a href="/">Home</a></li>
<li id="menu-item-295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-295"><a href="#">Connect</a>
<ul  class="sub-menu">
	<li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297"><a target="_blank" href="https://www.facebook.com/AM930TheLight">Facebook</a></li>
	<li id="menu-item-300" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-300"><a target="_blank" href="https://itunes.apple.com/ca/app/am-930-the-light/id404432211">iPhone App</a></li>
	<li id="menu-item-6519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6519"><a target="_blank" href="https://play.google.com/store/apps/details?id=com.shinefm.androidapp.light&#038;hl=en">Android App</a></li>
</ul>
</li>
<li id="menu-item-303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-303"><a href="#">On Air Lineup</a>
<ul  class="sub-menu">
	<li id="menu-item-2458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2458"><a href="/blog/personalities/robertdean/">Robert Dean</a></li>
	<li id="menu-item-2457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2457"><a href="/blog/personalities/lendehek/">Len Dehek</a></li>
</ul>
</li>
<li id="menu-item-152" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152"><a href="/events/">Events</a>
<ul  class="sub-menu">
	<li id="menu-item-2464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2464"><a href="http://www.am930thelight.com/add-community-event/">Share Your Event</a></li>
	<li id="menu-item-304" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-304"><a href="http://www.am930thelight.com/events/category/featured-events/">Featured Events</a></li>
	<li id="menu-item-2472" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-2472"><a href="http://www.am930thelight.com/events/category/community/">Community Events</a></li>
</ul>
</li>
<li id="menu-item-305" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-305"><a href="/contests/">Contests</a></li>
<li id="menu-item-306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-306"><a href="/churches/">Prayer &#038; Growth</a>
<ul  class="sub-menu">
	<li id="menu-item-307" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307"><a href="/churches/">Church Directory</a></li>
	<li id="menu-item-311" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-311"><a target="_blank" href="https://app.amenprayer.com">Amen</a></li>
	<li id="menu-item-331" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-331"><a href="http://www.am930thelight.com/prayers-and-growth/moment-of-truth/">Moment of Truth</a></li>
	<li id="menu-item-11427" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11427"><a href="http://www.am930thelight.com/apply-to-be-a-featured-church/">Apply to be a Featured Church</a></li>
</ul>
</li>
<li id="menu-item-315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-315"><a href="/advertisers/">Advertisers</a>
<ul  class="sub-menu">
	<li id="menu-item-316" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-316"><a href="/advertisers/">Advertisers List</a></li>
	<li id="menu-item-317" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-317"><a href="http://www.am930thelight.com/why-advertise/">Why Advertise?</a></li>
</ul>
</li>
<li id="menu-item-321" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="http://www.am930thelight.com/contact-us/schedule/">Schedule</a></li>
<li id="menu-item-335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-335"><a href="http://www.am930thelight.com/contact-us/">Info</a>
<ul  class="sub-menu">
	<li id="menu-item-320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-320"><a href="http://www.am930thelight.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-322"><a href="/jobs/">Jobs</a></li>
	<li id="menu-item-318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-318"><a href="http://www.am930thelight.com/artists/">Artists</a></li>
	<li id="menu-item-323" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-323"><a href="http://www.am930thelight.com/contact-us/frequently-asked-questions/">Frequently Asked Questions</a></li>
	<li id="menu-item-341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-341"><a href="http://www.am930thelight.com/contact-us/statement-of-faith-values-and-mission/">Our Mission</a></li>
</ul>
</li>
</ul></div>			</nav><!-- #site-navigation -->
		</header><!-- #masthead -->

		<div id="content" class="site-content">

<div class="grid grid-pad">

	<div id="primary" class="content-area col-6-12">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-12044" class="post-12044 post type-post status-publish format-standard hentry category-uncategorized">
	<header class="entry-header">
					<h1 class="entry-title">Do not delay</h1>				

		<div class="entry-meta">
					</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">
						<p class="m_1593422104867002800gmail-MsoNoSpacing">April 16 – Do not delay – Psalm 40:16-17</p>
<p class="m_1593422104867002800gmail-MsoNoSpacing">
<p class="m_1593422104867002800gmail-MsoNoSpacing">     David writes in these final verses of this psalm that all those who seek the Lord will rejoice and be glad.  Having a relationship with God brings out the best in those that really know Him.  Praise and worship are a result of grace.  David then encourages all who love the Lord`s salvation to say aloud, “The Lord is exalted.” That is what happened when the Jesus was entering Jerusalem on Psalm Sunday.  People were saying, “Blessed is He who comes in the name of the Lord.”</p>
<p class="m_1593422104867002800gmail-MsoNoSpacing">     In vs 17, David even though He is king recognizes his human condition.  David saw that he was needy and poor.  You can have all the wealth of the world but still be needy and poor.  Riches of this world have nothing to do with eternal life.  Without the Lord this is our condition.  David then says the Lord is his help and deliverer.  David was delivered from a bear, lion, Goliath, Saul, Absolom, the Philistines and himself.  His only prayer was that God would not delay.  Is that how you feel?  God help us and hurry.  God’s promises He will and your part is to trust Him.</p>
			</div><!-- .entry-content -->

	<footer class="entry-footer">
				
					<!-- facebook -->
	<div href="http://www.am930thelight.com/blog/do-not-delay/" class="fb-like" data-width="100%" data-layout="button_count" data-action="like" data-show-faces="true" data-share="true"></div>		
	<div href="http://www.am930thelight.com/blog/do-not-delay/" class="fb-comments" data-width="100%" data-numposts="8" data-colorscheme="light"></div>
	</footer><!-- .entry-footer -->
</article><!-- #post-## -->

				<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<div class="nav-previous"><a href="http://www.am930thelight.com/blog/life-with-out-god/" rel="prev"><span class="meta-nav">&larr;</span> Life with out God</a></div><div class="nav-next"><a href="http://www.am930thelight.com/blog/verse-today-656/" rel="next">Verse Today <span class="meta-nav">&rarr;</span></a></div>		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	
			
		
		</main><!-- #main -->
	</div><!-- #primary -->

		<div id="secondary" class="widget-area col-4-12" role="complementary">
		<aside id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="http://www.am930thelight.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside><aside id="tribe-events-adv-list-widget-4" class="widget tribe-events-adv-list-widget"><h1 class="widget-title">Upcoming Events</h1>
		<!-- Event  -->
		<div class="type-tribe_events post-12015 tribe-clearfix tribe-events-category-featured-events tribe-events-venue-6410">
			
<div class="tribe-mini-calendar-event event--1 ">
	<div class="list-date">
		<span
			class="list-dayname">Wed</span>
		<span
			class="list-daynumber">25</span>
	</div>

	<div class="list-info">
		
		<h2 class="tribe-events-title">
			<a href="http://www.am930thelight.com/event/edmonton-prayer-breakfast-3/" rel="bookmark">The Edmonton Prayer Breakfast</a>
		</h2>

		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">April 25 @ 7:25 am</span> - <span class="tribe-event-time">9:00 am</span>		</div>

		
		<div class="tribe-events-location">

			
			
			
			
			
			
			
			
		</div>

		
	</div> <!-- .list-info -->
</div>
		</div>

		
	
	<p class="tribe-events-widget-link">
		<a href="http://www.am930thelight.com/events/category/featured-events/" rel="bookmark">
			View More&hellip;		</a>
	</p>

</aside><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"The Edmonton Prayer Breakfast","description":"","url":"http://www.am930thelight.com/event/edmonton-prayer-breakfast-3/","startDate":"2018-04-25T13:25:00+00:00","endDate":"2018-04-25T15:00:00+00:00","location":{"@type":"Place","name":"Shaw Conference Centre","description":"","url":"http://www.am930thelight.com/venue/shaw-conference-centre-2/","address":{"streetAddress":"9797 Jasper Avenue Northwest","addressLocality":"Edmonton","addressRegion":"AB","postalCode":"NA"},"geo":{"@type":"GeoCoordinates","latitude":53.5412654,"longitude":-113.4868932},"telephone":"(778) 998-3577","sameAs":""},"offers":{"@type":"Offer","price":"50.00","url":"http://www.am930thelight.com/event/edmonton-prayer-breakfast-3/"}}]
</script><aside id="tribe-events-adv-list-widget-5" class="widget tribe-events-adv-list-widget"><h1 class="widget-title">Community Events</h1>
		<!-- Event  -->
		<div class="type-tribe_events post-12034 tribe-clearfix tribe-events-category-community">
			
<div class="tribe-mini-calendar-event event--1 ">
	<div class="list-date">
		<span
			class="list-dayname">Tue</span>
		<span
			class="list-daynumber">17</span>
	</div>

	<div class="list-info">
		
		<h2 class="tribe-events-title">
			<a href="http://www.am930thelight.com/event/edmonton-career-fair-training-expo/" rel="bookmark">Edmonton Career Fair and Training Expo</a>
		</h2>

		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">April 17 @ 10:00 am</span> - <span class="tribe-event-time">4:00 pm</span>		</div>

		
		<div class="tribe-events-location">

			
			
			
			
			
			
			
			
		</div>

		
	</div> <!-- .list-info -->
</div>
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-12007 tribe-clearfix tribe-events-category-community">
			
<div class="tribe-mini-calendar-event event--1 ">
	<div class="list-date">
		<span
			class="list-dayname">Sat</span>
		<span
			class="list-daynumber">28</span>
	</div>

	<div class="list-info">
		
		<h2 class="tribe-events-title">
			<a href="http://www.am930thelight.com/event/aglow-international-canada-8/" rel="bookmark">Aglow International Canada</a>
		</h2>

		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">April 28 @ 9:15 am</span> - <span class="tribe-event-time">11:45 am</span>		</div>

		
		<div class="tribe-events-location">

			
			
			
			
			
			
			
			
		</div>

		
	</div> <!-- .list-info -->
</div>
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-11934 tribe-clearfix tribe-events-category-community">
			
<div class="tribe-mini-calendar-event event--1 ">
	<div class="list-date">
		<span
			class="list-dayname">Tue</span>
		<span
			class="list-daynumber">01</span>
	</div>

	<div class="list-info">
		
		<h2 class="tribe-events-title">
			<a href="http://www.am930thelight.com/event/bring-faith-group-volunteer-habitat-humanity-4/" rel="bookmark">Bring your faith group to volunteer with Habitat for Humanity</a>
		</h2>

		
		
		<div class="tribe-events-duration">
			<span class="tribe-event-date-start">May 1 @ 8:30 am</span> - <span class="tribe-event-time">4:00 pm</span>		</div>

		
		<div class="tribe-events-location">

			
			
			
			
			
			
			
			
		</div>

		
	</div> <!-- .list-info -->
</div>
		</div>

		
	
	<p class="tribe-events-widget-link">
		<a href="http://www.am930thelight.com/events/category/community/" rel="bookmark">
			View More&hellip;		</a>
	</p>

</aside><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"Edmonton Career Fair and Training Expo","description":"&lt;p&gt;Spring is here, it\\'s time to kick start your new career! Career Fair Canada is back in Edmonton on April 17th! Don\u2019t miss your chance to network with some of...&lt;/p&gt;\\n","url":"http://www.am930thelight.com/event/edmonton-career-fair-training-expo/","startDate":"2018-04-17T16:00:00+00:00","endDate":"2018-04-17T22:00:00+00:00","offers":{"@type":"Offer","price":"0","url":"http://www.am930thelight.com/event/edmonton-career-fair-training-expo/"}},{"@context":"http://schema.org","@type":"Event","name":"Aglow International Canada","description":"&lt;p&gt;West Edmonton Lighthouse will be holding our monthly breakfast meeting with some of our National Team from our head office. Danyele Bloom Holtner, President, will share some opening remarks and...&lt;/p&gt;\\n","url":"http://www.am930thelight.com/event/aglow-international-canada-8/","startDate":"2018-04-28T15:15:00+00:00","endDate":"2018-04-28T17:45:00+00:00","offers":{"@type":"Offer","price":"20.00","url":"http://www.am930thelight.com/event/aglow-international-canada-8/"}},{"@context":"http://schema.org","@type":"Event","name":"Bring your faith group to volunteer with Habitat for Humanity","description":"&lt;p&gt;Habitat for Humanity Edmonton, in conjunction with the Capital Region Interfaith Housing Initiative, has hosted an Interfaith build project for the last six years. This year we hope to see...&lt;/p&gt;\\n","image":"http://www.am930thelight.com/wp-content/uploads/2018/03/Logo-2.jpg","url":"http://www.am930thelight.com/event/bring-faith-group-volunteer-habitat-humanity-4/","startDate":"2018-05-01T14:30:00+00:00","endDate":"2018-05-01T22:00:00+00:00","offers":{"@type":"Offer","price":"0.00","url":"http://www.am930thelight.com/event/bring-faith-group-volunteer-habitat-humanity-4/"}}]
</script>	</div><!-- #secondary -->
	
	<div id="skyscraper" class="col-2-12">
	<aside id="text-4" class="widget widget_text">			<div class="textwidget"><!-- /1710496/CJCA-Skyscraper -->
<div id='div-gpt-ad-1435266626324-0' style='height:600px; width:160px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1435266626324-0'); });
</script>
</div></div>
		</aside></div></div>
			
			<div style="padding:0 0 20px 0; clear: both;">
	<div id="sliderBoxWide">
		<div id="sliderBoxInside">
			<ul id="smWide" class="smWide">
				<!--<li> 
				<div id="slider1" class="slider" onclick="window.open('/prayers-and-growth/mentor-center/','_self');">
				<h1>The Shine FM<br>
				Mentor Center</h1>
				How can we pray for you? 
				</div> -->
				<!--div id="slider1" class="slider" onclick="window.open('/submitprayer/','_self');">
				<h1>PRAYER REQUEST</h1>Share your prayer request <br />
				with the Shine Team.
				</div-->
				</li> 
				<li> 
				<div id="slider2" class="slider" onclick="window.open('/add-community-event/','_self');">
				<h1>SUBMIT EVENT</h1>Let everyone know about<br>
				your event!
				</div>
				</li> 
				<li> 
				<div id="slider3" class="slider" onclick="window.open('http://visitor.constantcontact.com/manage/optin/ea?v=001iFzXxLROkcWksldWgx4Isw%3D%3D','_blank');">
				<h1>GET CONNECTED</h1>Join the Circle of Friends for email alerts and updates. 
				</div>
				</li> 
				<li> 
				<div id="slider4" class="slider" onclick="window.open('/contact-us/','_self');">
				<h1>CONTACT US</h1>Didn't catch that number? Need our address? Find it here. 
				</div>
				</li> 
			</ul>
		</div>
	</div>
</div>		
		</div><!-- #content -->

		<footer id="colophon" class="site-footer" role="contentinfo">	
			<div id="footer-leaderboard">
					<section id="text-6" class="widget widget_text">			<div class="textwidget"><!-- /1710496/CJCA-Leaderboard -->
<div id='div-gpt-ad-1491884663382-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1491884663382-0'); });
</script>
</div></div>
		</section>			</div>		
			<div class="site-info">
					<aside id="text-3" class="widget widget_text">			<div class="textwidget"><p>© 2018 Touch Canada Broadcasting (2006) Inc.</p>
</div>
		</aside><aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-54" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54"><a href="/">Home</a></li>
<li id="menu-item-350" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-350"><a href="http://www.am930thelight.com/why-advertise/">Advertise With Us</a></li>
<li id="menu-item-347" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-347"><a href="http://www.am930thelight.com/contact-us/">Contact Us</a></li>
<li id="menu-item-348" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-348"><a href="http://www.am930thelight.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-349" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-349"><a href="http://www.am930thelight.com/terms-of-use/">Terms of Use</a></li>
</ul></div></aside><aside id="text-7" class="widget widget_text">			<div class="textwidget"><p>*Standard Text Message Rates Apply*</p>
</div>
		</aside>		
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->
</div><!-- #flourish -->
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='http://www.am930thelight.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/themes/shine-fm/js/navigation.js?ver=20120206'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/themes/shine-fm/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-includes/js/wp-embed.min.js?ver=4.8.6'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/twitget/js/moment.js?ver=4.8.6'></script>
<script type='text/javascript' src='http://www.am930thelight.com/wp-content/plugins/twitget/js/langs.min.js?ver=4.8.6'></script>
<script type="text/css" id="tmpl-tribe_events_pro_customizer_css"></script><style type="text/css" id="tribe_events_pro_customizer_css"></style>		<div id="wprmenu_bar" class="wprmenu_bar">
			<div class="wprmenu_icon">
				<span class="wprmenu_ic_1"></span>
				<span class="wprmenu_ic_2"></span>
				<span class="wprmenu_ic_3"></span>
			</div>
			<div class="menu_title">
								<img class="bar_logo" src="http://www.am930thelight.com/wp-content/uploads/2016/07/am-930-the-light-1.png"/>			</div>
		</div>

		<div id="wprmenu_menu" class="wprmenu_levels left wprmenu_custom_icons">
						<ul id="wprmenu_menu_ul">
				<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-295"><a href="#">Connect</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297"><a target="_blank" href="https://www.facebook.com/AM930TheLight">Facebook</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-300"><a target="_blank" href="https://itunes.apple.com/ca/app/am-930-the-light/id404432211">iPhone App</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6519"><a target="_blank" href="https://play.google.com/store/apps/details?id=com.shinefm.androidapp.light&#038;hl=en">Android App</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-303"><a href="#">On Air Lineup</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2458"><a href="/blog/personalities/robertdean/">Robert Dean</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2457"><a href="/blog/personalities/lendehek/">Len Dehek</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152"><a href="/events/">Events</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2464"><a href="http://www.am930thelight.com/add-community-event/">Share Your Event</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-304"><a href="http://www.am930thelight.com/events/category/featured-events/">Featured Events</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-2472"><a href="http://www.am930thelight.com/events/category/community/">Community Events</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-305"><a href="/contests/">Contests</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-306"><a href="/churches/">Prayer &#038; Growth</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-307"><a href="/churches/">Church Directory</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-311"><a target="_blank" href="https://app.amenprayer.com">Amen</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-331"><a href="http://www.am930thelight.com/prayers-and-growth/moment-of-truth/">Moment of Truth</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11427"><a href="http://www.am930thelight.com/apply-to-be-a-featured-church/">Apply to be a Featured Church</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-315"><a href="/advertisers/">Advertisers</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-316"><a href="/advertisers/">Advertisers List</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-317"><a href="http://www.am930thelight.com/why-advertise/">Why Advertise?</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-321"><a href="http://www.am930thelight.com/contact-us/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-335"><a href="http://www.am930thelight.com/contact-us/">Info</a>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-320"><a href="http://www.am930thelight.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-322"><a href="/jobs/">Jobs</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-318"><a href="http://www.am930thelight.com/artists/">Artists</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-323"><a href="http://www.am930thelight.com/contact-us/frequently-asked-questions/">Frequently Asked Questions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-341"><a href="http://www.am930thelight.com/contact-us/statement-of-faith-values-and-mission/">Our Mission</a></li>
</ul>
</li>
			</ul>
					</div>
		<script type="text/javascript" src="/wp-content/themes/shine-fm/js/functions.js"></script>
</body>
</html>
